Exam: 640-802
Exam Objective: Configure, verify, and troubleshoot RIPv2
Contents
- Introduction
- Technology Background
- Lab Scenario
- Lab Objectives
- Lab Solution
Introduction
There are three types of routing Protocols - Distance Vector, Link-State and Hybrid. The distance-vector routing algorithm sends complete routing table information to neighboringRouters at periodic intervals, which then combine the received routing information with their own routing tables to create the routing table.
RIP is a distance vector protocol and has two version - 1 and 2.
Technology Background
RIPv2 multicasts its entire routing table every 30 seconds to the multicast address 224.0.0.9. It uses hop counts to determine the best path to a destination network but it has a limit of 15 hops. Which means if a network is found to be more than 15 hops away then that route will be discarded as unreachable.RIPv2 support classless routing updates (sends subnet mask information in routing updates) unlike RIPv1.
RIP uses many timers to maintain its routing table and interact with its neighbors. There are:
Route Update Timer: The routing-update timer clocks the interval between periodic routing updates. Generally, it is set to 30 seconds, with a small random amount of time added whenever the timer is reset.
Route invalid timer: It is the length of time that must elapse (180 seconds by default) before a
router determines that a route has become invalid. This means if a Router hasn't heard about a route for 180 seconds (by default) then it will assume that the route has been lost. When that happens, the router will send out updates to all its neighbors letting them know that the route is invalid.
Holddown timer: This sets the amount of time during which routing information is suppressed.
Routes will enter into the holddown state when an update packet is received which indicates that the route is unreachable. This continues either until an update packet is received with a
better metric or until the holddown timer expires. The default is 180 seconds.
Route flush timer: Sets the time between a route becoming invalid and its removal from the
routing table (240 seconds). Before it's removed from the table, the router notifies its neighbors
that route has been lost. The value of the route invalid timer must be less than that of the route flush timer.
The following steps are required to enable RIP:
- Enable the RIP process using the following command:
Router(config)#router rip
- Set the version to 2:
Router(config-router)#version 2
- Specify the networks to be advertised:
Router(config-router)#network <network>
It should be noted that the networks can
be added in their classful form only. RIP will advertised any networks
connected the router which fall under the classful boundary but will add
the subnet mask configure on the interfaces.
For Example, let's look at the configuration below:
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.128
!
Interface FastEthernet0/1
ip address 192.168.1.129 255.255.255.128
!
router rip
version 2
network 192.168.1.0
!
This router will advertise both the
networks with a /25 mask and will also enable the RIP process on both
the interfaces. Which means it will receive and send routing updates
through fa0/0 and fa0/1
RIP can be configure not to send updates out on a interface using the passive-interface <interface>command under the routing process. An interface configured as passive under RIP will continue receiving updates though.A few commands which can be used to verify and troubleshoot RIP are:
- show ip route - Shows the routing table of the router
- show ip protocol - Shows all Routing protocols running and their parameters
- sh ip rip database - Shows the RIP database
- debug ip rip - Shows debugs of rip process
Lab Scenario
Your task is to configure the network shown in Figure 1, such that:- RouterA and RouterB know all the 192.168.x.0 networks
- RouterC does not know the 192.168.1.0/24, 192.168.2.0/24 and 192.168.3.0/24
- RouterC should be configured with a default route to reach the networks it does not know
Figure 1
Lab Objectives
- Enable RIP on all routers and advertise all networks
- Make the fa0/1 interfce of RouterB a passive interface
- Add a default route on RouterC pointing to 192.168.4.1 (RouterB's fa0/1 interface)
Lab Solution
First we need to enable RIP and advertise all networks on all Routers:RouterA(config)#router rip
RouterA(config-router)#network 192.168.1.0
RouterA(config-router)#network 192.168.2.0
RouterB(config)#router rip
RouterB(config-router)#network 192.168.2.0
RouterB(config-router)#network 192.168.3.0
RouterB(config-router)#network 192.168.4.0
RouterC(config)#router rip
RouterC(config-router)#network 192.168.4.0
RouterC(config-router)#network 192.168.5.0
Now we need to ensure that RouterC does not get routes from RouterA and RouterB but sends routes to them. So we need to make the fa0/1 interface on RouterB passive. This will ensure that it gets routes from RouterC but does not send any:
RouterB(config-router)#passive-interface fa0/1
Finally we add a default route on RouterC to ensure that it can get to all the networks:
RouterC(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
Let's verify the configuration:
RouterA#show ip route
--output truncated--
Gateway of last resort is not set
R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:06, FastEthernet0/0
R 192.168.5.0/24 [120/1] via 192.168.2.2, 00:00:04, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/1
C 192.168.2.0/24 is directly connected, FastEthernet0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:06, FastEthernet0/0
RouterB#show ip route
--output truncated--
Gateway of last resort is not set
C 192.168.4.0/24 is directly connected, FastEthernet0/1
R 192.168.5.0/24 [120/1] via 192.168.4.2, 00:00:01, FastEthernet0/1
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:15, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, FastEthernet0/2
RouterC#show ip route
--output truncated--
Gateway of last resort is 192.168.4.1 to network 0.0.0.0
C 192.168.4.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.4.1
RouterA#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 8 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
192.168.2.0
Routing Information Sources:
Gateway Distance Last Update
192.168.2.2 120 00:00:10
Distance: (default is 120)
References:
Network Protocols Configuration Guide, Part 1 - Configuring RIP:
http://www.cisco.com/en/US/docs/ios/11_3/np1/configuration/guide/1crip.html
Internetworking Technology Handbook - Routing Information Protocol (RIP)
http://www.cisco.com/en/US/docs/internetworking/technology/handbook/RIP.html
No hay comentarios.:
Publicar un comentario